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Introduction

elcome to the user’s guide for

Hank — a special purpose

cognitive modelling language that
is designed to be easy for psychologists to learn

and to use.

If you’re an expert in cognitive modelling, or if
you’re just learning how to do it, Hank is a
great tool to use, because it allows you to focus
on the model you’re building at a high level,
reducing the amount of time you spend worry

about programming.

About this guide

This guide will give you an overview of the
Hank environment on a Windows computer.
It is not a complete guide to cognitive
modelling. If you want a fuller introduction to
cognitive modelling in Hank, please contact us
and ask for a copy of the Cognitive Modelling
Project booklet, which covers all the basics of

cognitive modelling.

The Cognitive Modelling Project booklet is
designed to be independent of this computer
program, and can be used to in a cognitive
modelling course without the need for access to

a computer at any stage.

However, Hank (at least when supported by a
computer program) goes considerably more
deeply into modelling than the Cognitive
Modelling Project booklet can support.

This user’s guide covers the Hank program for
Windows, and shows how it can be used to
build and run substantial cognitive models. It
also covers all the advanced features of the Hank
language which are not mentioned in the

Cognitive Modelling Project booklet.

Contacting us

If you want to get in touch with the team that

developed and is supporting Hank, you can

send an email message to mailto:kmi-

hank@open.ac.uk, or you can go to the web

site http://kmi.open.ac.uk/projects/ hank/.
Finally, you can also contact us by post at: Hank

Support Group, Knowledge Media Institute,
The Open University, Walton Hall, Milton
Keynes MK7 6AA, UK.

Registration

Although the Hank software is free, it would
help us greatly if you would register your
software. That way, we can inform you when
new versions are available, and respond to any
comments or requests that you may have

regarding Hank.

To register
Enter the URL

http://kmi.open.ac.uk/hank/register.htm into
your browser, and complete the form it ofters

you.



Chapter 1. Getting started with Hank

ank is a specially designed
environment for designing,
building, and running, and

psychological cognitive models.

The Hank web site

There is a site on the world wide web dedicated
to Hank, where you can find out about some of
the models that have been developed using
Hank, and where you can always get the latest
version of the Hank program. To go to the
Hank web site, enter the URL
http://kmi.open.ac.uk/hank/ in your web

browser.

You can also get the latest version of Hank from
this web site, by entering the URL
http://kmi.open.ac.uk/hank/downloads/, the
downloads page of the Hank web site. This
page will tell you how to get and install this

latest version of the Hank program.

What computer do | need?

At the moment, Hank is only available for
‘Windows computers, running Windows 95, 98,
or NT. However, Hank should also work fine
with Windows 3.1, using the Win32S upgrade
pack. You can obtain this from us if you need

it.

Installing Hank

Before you can use Hank, you need to install it.
Hank is free and does not come with any copy
protection — indeed, we encourage you to tell
your friends about it. However, we would be
grateful if you would register the program with
us, so we can keep you informed with the latest
developments in Hank, and so that we can
provide a cognitive modelling environment that

really meets the needs of psychologists.

To install Hank:
1 Put the Hank floppy disk into your PC’s
floppy disk drive

2 Start the Hank installer by selecting Start >
Run..., then entering “a:setup” choosing
OK.

3 Follow the guidance given in the Hank

installation program.

Running Hank

To start Hank
1 Choose Start > Programs > Hank > Hank
If you installed Hank in a different program

folder, choose that folder instead from the Start

menu.

To leave Hank

1 Choose File > Exit



Chapter 2. Using Hank to build models

hen you’ve managed to install and
run Hank, you’re ready to be

begin building cognitive models.

If you’re not familiar with cognitive modelling,
this is the right time to get a copy of the
Cognitive Modelling Project booklet, which will
give you a good tutorial and overview of the
modelling process, and cover most of the theory

behind cognitive modelling.

Creating and opening Hank
databases

In Hank, models are held in databases. The
Hank software environment holds each database
in a different file. You can create, open, and
use as many databases as you like, even at the

same time.

The New command allows you to create a

new, empty, database file.

The Open... command lets you open an
existing Hank database file. The command will
offer you the standard file choosing window to

let you choose the file.

Hank database files have the file extension

“ hnk”.

To create a new Hank database

1 Choose File > New

To open an existing Hank database file

1 Choose File > Open...

2 Choose the name of the Hank database file

that you want to open, and select Open.

To save an open Hank database

1 Select the window containing the Hank

database

2 Choose File > Save

To print an open database

1 Select the window containing the Hank

database
2 Choose File > Print...

3 Complete the standard print dialog, and
press OK to print the database

Note: You can change the print settings either in the
Print... dialog, or by choosing the Edit > Page

Setup... command.

Working with cards

The main building blocks of Hank models are
cards. Hank uses two different kinds of fact,
fact cards which are used to represent factual
items — knowledge which is simply known,
and instruction cards, which represent processes
used to work out knowledge which isn’t
available directly, or at least shouldn’t be

according to your model.

Cards are created and changed using the Cards

menu.

Using fact cards

To create a new fact card

1 Choose Cards > New Fact Card

This will add a new untitled fact card into the
database.

Although they start with two rows and two
columns, fact cards can have any number of
rows or columns, and you can change the

number of rows or columns at any time.

Changing the size of a fact card

1 Move the mouse to the bottom right of the

fact card, over the resize tab, until the cursor



changes to the double-ended resize arrow

r,.

2 Drag the mouse to change the number of

rows or columns.

Changing the contents of a fact
card

Each fact card behaves a bit like a small
spreadsheet. You can edit the data in each cell

by clicking on the cell and typing a new value.

When the mouse is over a cell which can be

edited, the pointer becomes a cell selector

To change the contents of a cell

1 Move the mouse over the cell, until the

pointer becomes the cell selector Gp

2 Click the mouse, and the cell’s contents will

become editable.
3 Type a new value into the cell.
4 When you’re done, press the Enter key.

‘While editing one cell, if you press the Tab key,
the contents of that cell will be entered and the
next cell will automatically become editable. If
you press Shift + Tab, the previous cell will
become editable. Simply by typing new values
separated by the Tab key, therefore, you can

completely change a fact card’s content.

Using instruction cards

To create a new instruction card

1 Choose Cards > New Instruction Card

This will add a new untitled instruction card

into the database.

Although they start with a wish box containing
two columns, instruction cards can have any
number of columns, and you can change the

number of columns at any time.

Changing the size of an instruction card’s
wish box

1 Move the mouse to the bottom right of the
instruction card’s wish box, over the resize
tab, until the cursor changes to the double-

ended resize arrow.

2 Drag the mouse to change the number of

columns.

You can also change the size of the instruction
card’s process box, to give you plenty of room
to describe how the instruction card will

behave.

Changing the size of an instruction card’s
process box

1 Move the mouse to the bottom right of the
instruction card’s process box, over the
resize tab, until the cursor changes to the

double-ended resize arrow.

2 Drag the mouse to change the size of the

process box.

Changing an instruction card’s wish box

An instruction card’s which box behaves just
like a fact card, except that you can’t change the
number of rows. To edit the wish box, when
you change the instruction card’s title, column
labels, and so on, you move the mouse over the
cell until the pointer changes to the cell
selection pointer §p, and then click.

To add a question to an instruction card’s
process box

1 Select the instruction card
2 Choose Cards > New Question Box

If you want to add a built in question from the
Gallery, choose Cards > New Question from
Gallery... instead.

Hank always starts a process with the question
box at the top left of the process box. To
arrange this, and to ensure that the layout of the
process box is nice and neat, you will probably
want to move question boxes around inside an

instruction card.



To move a question box in an instruction
card

1 Move the mouse over the question box.

2 Drag move the question box until it is
where you want, and then let go the mouse

button.

Note: If the question box is already selected, towards
the edges of the question box the pointer may change
to the link pointer {f or the resize pointer, Hank
will try to link questions or resize a question rather
than move one. To move a question, make sure that
the pointer is either the usual arrow, or the cell
selection pointer S

Hank runs a process by asking questions, and
then following a link arrow that matches the
status of the previous question. To build a
proper process, then, you need to be able to

link questions together.

To link one question to another

1 If the first question isn’t already selected,

select it by clicking on it with the mouse.

2 Move the mouse to the edge of the first
question, where you want to link from, and
wait for the cursor to change to the link

pointer {? .

3 Drag the link to the question box you want
to link to, until the target point highlights.
When you let go the mouse button, a new

link will be created.

Links can either be unlabelled (in which case
Hank can always follow the link) or they can be
labelled “OK” or “Fail”, in which case Hank
will only follow the link if it matches the
current status. This means you need to be able

to change a link’s label.

To change a link’s label
1 Select the link by clicking on it with the

mouse

2 Change the link’s label by choosing an

appropriate command from the Edit menu.

e To remove a link’s label choose Edit >
Unlabel Link.

e To set the link’s label to “OK” choose
Edit > Label Link “OK”.

e To set the link’s label to Fail choose Edit
> Label Link “Fail”.

To delete a card, question box, or a link

1 Select the card, question box, or link.

2 Choose Edit > Delete, or press the Del key.

Managing a large database

Instruction cards and fact cards can grow to be
quite big, so Hank provides a way of ‘folding’
cards to make them smaller. This can help you
to fit many more cards into a database in an

accessible form.

To fold a card

1 Select the instruction card
2 Choose Edit > Fold Card

Alternatively, you can double-click on a card’s

title to fold it, if it is currently not folded.

To unfold a card

1 Select the instruction card
2 Choose Edit > Unfold Card

Alternatively, you can double-click on a card’s

title to unfold it, if it is currently folded.

Running models in Hank

At any time, you can ask Hank to try to run
your model, even if it is not yet fully complete.
The commands needed to run models are all the

Ask menu.

Hank allows you to run models in two different
ways, briefly and in full. If you ask a question
briefly, it is run as fast as possible, and (apart

from tracing built into the model, through



“Say” questions, for example) little feedback is
given. If you run a model in full, it is run
through the workspace so you can see every

single intermediate step in the model’s action.

To run a model briefly

There are two different ways of running a
model briefly. You can do either of the

following:
*  Use the control panel

* Select a question, then use the Ask > Ask

Briefly command

Using the control panel

The control panel is a special window that you
can use to ask Hank’s question processor to

work something out for you.

To open the control panel

1 Choose Window > Control Panel, or press
the F9 key

Then the control panel, which looks like this,

will appear.

4 Control Panel

II=] E3

e ]
Ha“ﬁay__‘l-— — — 1 Agk Briefly |
Iknow about _Jcanary o AskinFul |

Hank says: Hello =

ou ask Hank: "Hank: Say with | know ahout, Canan®
Hank says: | know about Canary
Status = Ok

There are three parts to the control panel, a
question panel, a button panel, and a transcript

window.

If you press “Ask Briefly” the question
currently in the question panel will be put to
the question processor immediately, and the

response printed.

To ask a question briefly using the
control panel

1 Change the question, as if it was a fact card

2 Press “Ask Briefly”

To ask a question in full using the control
panel

1 Change the question, as if it was a fact card
2 Press “Ask in Full”

If you press “Ask in Full” the question will be
passed to the workspace window, where you
can watch the question processor run your

model in much fuller detail.

Note: You can copy the contents of the transcript
window by selecting it and using Edit > Copy. You
can then paste the entire transcript into a word

processor, for example.

Using the workspace window

Once a question has been passed to the question
processor, you can use the workspace window

to watch it working the answer out for you.

To open the workspace window

2 Choose Window > Workspace, or press the
10 key

Then the workspace window will appear.

£ Workspace M=l

«l 4 | lI ’Jil Step number: 0

il

Hark: Say |

| know about |[Canary

T

-

At the top of the workspace window is the

stepping panel, which contains a set of buttons



vaguely resembling those you find on a video or

cassette recorder.

W dufrn

The buttons work like this:

H | Rewind. The button returns the
question to its starting state. If you
want to stop rewinding, press the Stop

button.

4 | Back. This button moves the question

back one step.

| | Stop. Ifthe question is currently
rewinding or running, pressing this

button will stop it.

Ll Step. This button moves the question
forward one step. To single step a
model, simply press this button
repeatedly.

[ | Run. This button runs the model
forwards, until the end. To stop
running the model, press the Stop

button.

As you run through the workspace window,
each new instruction card is shown as a new
row in the workspace. Also, questions are
shown in two colours as they run. First they are
shown in red (the Ask) step, and then they are
shown in black (the Match) step.

Running questions from the model

You don’t have to use the control panel to ask
questions. You can also ask them directly from

the model, in two ways.

Asking questions from the model

1 Select the question you want to ask (it may

be a step in an instruction card)

2 Choose Ask > Ask Briefly or Ask > Ask in
Full

This will copy the question into the control
panel and automatically choose the “Ask

Briefly” or “Ask in Full” button for you.

User query cards

The other way of asking questions directly from
the model is to use user queries. These look
and behave like question boxes, except that

they can live outside an instruction card.

To add a user query to a database

1 Choose Cards > New User Query

2 Change the contents of the new user query,

so that matches the question you want to

ask.

To run a user query

Simply double-click the user query. This is the
same as selecting the user query and choosing
Ask > Ask Briefly. It will copy the user query
into the control panel and choose the “Ask
Briefly” button, running it immediately in the

control panel.

Note: You can also hold down the Alt key while
double clicking. This is the same as selecting the user
query and choosing Ask > Ask in Full. The user
query will be passed to the workspace window for a

Sfull run.

The debugger

Like any programming language, Hank models
sometimes hit problems. When this happens,

Hank will often display the debugger window.

The debugger window describes the problem,
and gives you a list of options for carrying on.
Generally speaking, it’s usually best to choose

“OK” to accept Hank’s recommended option.

Card "Minus" doesn't match the question's calumng

[Continue) Ta carry on, after setting the status ko *Fail”, choose this option.

Often this option will allow you to carry on,

even in the middle of running a question.



Chapter 3. Doing more with Hank

There are a lot of additional sides to the Hank
language that aren’t covered in either the
previous chapter, or even in the Cognitive

Modelling Project booklet.

Some of these features are special to the
computer environment; you can export models
in a form that you can include in a word
processed report, for instance. Many of these
features are straightforwardly similar to other
computer programs. Printing, for example,
works in Hank more or less identically to any

other computer program in Windows.

However, there are a number of features that
are special to the Hank language, which may
help you to develop rather more powerful

models than you have seen so far.

Built in questions

So far, you will mostly have come across
questions that the question processor handles
through your own fact and instruction cards.
However, Hank has a lot of ‘built in” questions
which it can answer itself; you can think of
these as working by using built in instruction

cards.

Some of these built in questions can do things
that would be impossible to do in any other
way. For example, there is a built in question
you can ask (“Hank: Add to Card”) which adds
a new row to a fact card, and there are a whole
bunch for mathematics, addition, subtraction,

and so on.

You can see the full list of built in questions by
using the New Question from Gallery...
command. This opens the Gallery, described in
chapter 4, which lists and describes all the built
in questions that Hank knows about. For more

details, see chapter 4.

To open the Gallery of built in questions

1 Choose Cards > New Question from

Gallery...

Whatever happened to
backtracking? “Ask” and “Ask All”

Hank does not support backtracking, so once
you’ve explored one match from a fact card,
Hank will not automatically go back and look
for another match if the process fails somewhere

further down the line.

This is the normal behaviour in Hank, and is
implemented by the “Ask” built in question. In

other words, the two questions:

(LI
[Cetegory ___ [Superordinate
[Canary _~  PWhat? |
e Asi s akingof ]
[Cotegory ___ | Superordinate
[Canary _ |PWhat? |

are identical in all respects.

Ask will always give you the first match that is
available. It works with both fact cards and

instruction cards.

This can sometimes be quite limiting, as it
means there is no way to look for all the
possible matches. To overcome this limitation,
Hank provides a special built in question “Ask
All”, which lets you check all the available
matches in order, but which only works for a

fact card. You might use it like this:

—_—

I_C—ategory J_Superordinate
[PSomeihing?__[Awhat

This question would pick up the first row in the
“Is a kind of”’ fact card with status “OK”, and
then, if you go back into it, would pick up the

second row with status “OK”, and so on. Only



when no more matching rows are available
would the question fail. The following

instruction card shows this pattern in practice:

Say all

OK

?Something? _ |

You can use “Ask” and “Ask All” (which you
can think of as providing explicit backtracking
within an instruction card) to provide all the
important behaviour of backtracking, while still

remaining fairly easy to understand.

Composite matching

Composite matching is a way to treat a value as
something that can be divided, manipulated in

separate parts, and then recombined.

A value in Hank is actually a list of elements.
For example, the value “1 + 2 = 3” is actually

made up of five elements.

A single variable can match against any number
of elements, so if you use single variables
everywhere, you don’t even need to be aware
of composite matching. Composite matching
only happens when you use more than one
variable in a cell, or when you mix variables and

values in a cell.

Let’s look at some examples:

You can also use variables that have an acquired
value in composite matching, and to construct
values. So, for example, if ?Sum? has the
acquired value “1 + 27, a value “?Sum? = 3”
will behave as “1 +2 = 3",

Another important point about composite
matching is the way that lists of different lengths
are handled. Here the approach is simple: when
a list of variables match a list of values, every
variable must have at least one value, and the
first variables take a value each, and the last

takes any that are left over.

Let’s look at some examples of this:

Pattern Value Match result

?A? 1234 PA?=1234

?A? ?B? 2C? ?D? 1234 PA?=1

B2 =2
2C2=3
:D? = 4
2A? ?Rest? 1234 [A?=1
Rest? =23 4
2A?7B22C?22D? 123 No match

Pattern Value Match result

?Sum? 1+2=3 PSum?=1+2=3

PA?+?B?=2C? |[1+2=3 |[PA?=1

B>=2
C?=3
?Sum? =3 1+2=3 |?PSum?=1+2

?Sum? = 4 1+ 2 =3 |No match

Composite matching, then, uses a sequence of
values in a pattern to cut up a value into a
corresponding sequence of values for each
sequence of variables. Then the list matching
rules are applied. The end result is exceedingly
powerful. For example: “?X? remember 2Y?”
will match “I can remember last Sunday’s
picnic”, so that ?X? will acquire the value “I

can”, and ?Y? “last Sunday’s picnic”.

Getting Hank to talk

It is often useful to get Hank to print out some
text as the model runs. You can use this either
to provide a ‘behind the scenes’ watch on the
model’s behaviour, or actually as part of the
model itself — modelling, for example, a

participant’s responses to stimuli.




To ask Hank to print out something, you can
use the built in questions “Say” and “Say In

Dialog”. For example, the question:

|_| know about J_?gm_ethﬂ;’?_ i

will, when Hank runs it, print out:
Hank says: | know about Canary

in the transcript part of the Control Window, if
the variable ?Something? currently has the value
Canary. The “Say” built in question always sets
the status to “OK”.

The other built in question, “Say In Dialog”, is
rather similar, except that the text is written in a
dialog window rather than in the transcript.
The dialog contains an “OK” button and a
“Fail” button, and the status will be set to
correspond to the button chosen. You can,
therefore, use the “Say in Dialog” question to

ask someone which course of action to follow.

Changing the database

One of the more powerful features of Hank is
that a model can change the fact cards that it

uses, as well as just matching on them.

There are four built in questions that you can
use to do this, and they come in pairs. “Add to
Card” and “Remove from Card” are the
simplest to use, they simply add a new row, or
remove an existing row, from a fact card. If the

fact card doesn’t exist, it will be created.

Alternatively, you can change a fact card using
“Get Cell Value” and “Put Cell Value”, which
allow you to treat a fact card more as if it is a
proper spreadsheet, reading and writing a cell’s
value by specifying the row and column for that

cell.

Note: in all cases, Hank will make the changes to the
database immediately, so you can see fact cards change

within the database as your model runs.

To add a new row to a fact card

Use a question a bit like this:

—_—
- - - - —— —— —

|_?Va|ue’? J_An_imi__J

A new row will be added to the end of the fact
card, containing whatever is in the variable

?Value?, and the value Animal.

To remove a matching row from a fact
card

Similarly, you can use a question like this:

I'Emk: Remove from Card: Is a kind of

I_C—ategory _éu pe_ror_dinﬁe_ o
[Pvalue?  JAnimal ]

to remove a matching row from a fact card.
The first matching row within the fact card will

be removed.

Hint: Using “Add to Card” and “Remove from
Card” together, you can give models a kind of
‘memory’, so that they can remember (and also forget)

previous results.

To get a cell’s value from a fact card

To get a cell’s value, you can use a question like
this:

Swpeordnate |1 [vawr |
You can refer to the column either by name or
by number. In this case, the question will put
the contents of the given cell into the variable
?Value?.

To change a cell’s value in a fact card

To change the value of a cell in a fact card, you

can use a question like this:

- s -
liilumi lRow iVaIue i
(Superordinate |1 JAnimal |

Again, you can refer to the column either by

name or by number. In this case, the value in



the Superordinate column, in the first row, will

change to Animal.

Hint: Using “Get Cell Value” and “Put Cell
Value” together, you can treat a fact card as a two-
dimensional array. This can be very useful for
mathematically oriented models, such as those based

on parallel distributed processing.

Draw values

So far, every value that you’ve seen has been
drawn by Hank as simple text. Sometimes,
though, it is useful to draw text differently,
using different colours, or even to simply fill in

cells in a fact card with coloured blocks.

Draw values let you do this. If a value begins

bl

“Draw:” it can contain a set of keywords and
values which tell Hank to draw the value
differently. The keywords end with a

semicolon.

So, for example, “Draw: Colour: Red; Hello
World” would be drawn as “Hello World”, but
in red text. “Draw: Background: Green; This is
green” would be drawn as “This is green” on a
green background. You don’t even need text
to follow the semicolon, so, for example
“Draw: Background: Grey” simply fills a cell
with grey.

Underneath, Hank uses the full text as the
value, so if you click on one of these values, the

full text is shown and can be changed.

Hank currently only knows about two draw
value keywords, “Colour” and “Background”,
both of which take a colour value. The colours
allowed are “Red”, “Green”, “Blue”,
“Magenta”, “Cyan”, “Yellow”, and “Grey” (or
“Gray”) — all of which may be preceded by
either “Light” or “Dark”. Hank also allows
“White” and “Black”.

Exporting pictures from Hank

Currently Hank does not allow cards to be
copied as pictures to be pasted into a word

processor.

If you want to embed a graphic from Hank, you
can use the File > Export... and File > Export

Selection... commands.

To export a whole window

1 Select the window
2 Choose File > Export...

3 Enter the file name and export format type
for the file you wish to create. Currently,
Hank only supports the EPS (Encapsulated
PostScript) graphic format.

4 Choose Save to export the file

The File > Export... command will work both
for a database window, and also for a workspace

window.

To export part of a database window

1 Select the window and within it, the objects

you wish to export.
2 Choose File > Export Selection...

3 Enter the file name and export format type
for the file you wish to create. Currently,
Hank only supports the EPS (Encapsulated
PostScript) graphic format.

4 Choose Save to export the file

The File > Export Selection... command will
only work with database windows, not with the
workspace window. You cannot export a

selected part of a workspace window.

To include an exported picture in a word
processor file

Check the documentation that comes with
your word processor. In Microsoft Word, for
example, you can choose Insert > Picture >
From File... and select the file containing the

exported Encapsulated PostScript file.

Note: Currently Hank does not save a picture
preview for exported EPS files. This means that the
included element is unlikely to display properly in the
word processor. It will, however, print properly on a

PostScript printer.






Chapter 4. The Gallery

ank’s computer environment offers a

large range of built in questions that

you can ask. A full list of these
questions is available in the Gallery. (Ifyou
can’t find a special question that you need here,
it’s worth checking the computer environment,
because new releases of the program sometimes
include new built in questions. If' you still can’t
find it, let us know — we may be able to add it

in a new version.)

Using the Gallery

The gallery describes all the built in questions

you can use in Hank.

To open the Gallery

1 Choose Cards > New Question from

Gallery...

To add a built in question

1 Choose Cards > New Question from

Gallery...

2 Select the built in question from the
displayed list of all available questions.

3 Choose Add to Database to add the question
to the database. Ifan instruction card is
currently selected in the database, the
question will be added into the process box
of the instruction card. Otherwise, the new

question will be added as a new user query.

Currently, Hank provides all these built in
questions. The descriptions are all shown in the
Gallery window as well as here in this reference,
so if you are unsure of the exact behaviour of a
built in question, the Gallery itself may be able
to help you choose which built in question to

use.

Hank: Add
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Use the Add card to add two numbers together.
If you put the numbers you want to add into
the first two columns, and an empty value box
in the third, Hank will add the numbers and put

the answer into the empty value box.

Hank: Add to Card
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Use Add to Card if you want to add a new row
to a Fact Card. Give the name of the Fact Card
in the title, for example, to add to a card
“Upon”, use “Hank: Add to Card: Upon”.
Hank will then look for this Fact Card, or make
it if needed, and then add the new row at the
end of the card.

Hank: Ask
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Use the Ask card to look for a match in a Fact
Card, Give the name if the Fact Card in the
title, for example, to look in a card “Upon”, use
“Hank: Ask: Upon”. Hank will then look for
this Fact Card, and will try to find a matching
row. Ifarow is found, Hank will set the status

to OK, otherwise Fail.

Hank: Ask All
[Hank: Ask All: My Card ]
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Use the Ask card to look for a number of

matches in a Fact Card, Give the name if the



Fact Card in the title, for example, to look in a
card “Upon”, use “Hank: Ask All: Upon”.
Hank will then look for this Fact Card, and will
collect all the matching rows. Each time you
return to this question, you'll get the next
matching row until none are left, when Hank

will set the status to Fail.

Hank: Ask In Dialog

Use the Ask In Dialog card to get some input
from a user. Hank will then put up a dialog
window and offer the user a chance to type in a
value. This value will then be matched against
the pattern in the Pattern column. If the two
match, then the status is set to OK and any
variables in the pattern will acquire values.
However, if they don't match, or if the user
doesn’t give a value, the status will be set to
Fail.

Hank: Card Size
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Use the Card Size card to find out how big a
Fact Card is. Give the name of the Fact Card in
the title, for example, to look in the card
“Upon”, use “Hank: Card Size: Upon”. Hank
will then look for this Fact card, and match the
Columns and Rows values with the number of
columns and rows in the Fact Card, returning
any variables in these parameters. If the match

fails, the status will be set to Fail.

Hank: Copy
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Use the Copy card to put a value into a value
box. The Copy card has two columns, and puts
the value in the From column into the value

box in the To column. (Hank doesn't care

which order the columns are in, it looks for the

columns by name.)

Hank: Decrement

[Hank: Decrement |
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Use the Increment card to subtract an amount
from a variable, which should already contain a
number. Put the variable in the first column,
and the amount you want to subtract from it in
the second column, and Hank will subtract the

amount from the variable.

Hank: Divide
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Use the Divide card to divide one number by
another. If'you put the numbers you want to
divide into the first two columns, and an empty
value box in the third, Hank will divide the first
by the second and put the answer into the

empty value box.

Hank: Exit
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Use the Exit card if you want to tell Hank to
stop work on an Instruction Card. The Exit
card also expects a value, which Hank puts into

the status when ending the Instruction Card.

Hank: Get Cell Value
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Use the Get Cell Value card to get the value
from a Fact Card’s cell. Give the name of the
Fact Card in the title, for example, to look in
the card “Upon”, use “Hank: Get Cell Value:
Upon”. Hank will then look for this Fact Card,
find the given column and row, and put the

value it finds into the (empty) value box,



Result. If Hank couldn't get the cell for some

reason, the status will be set to Fail.

Hank: Get Status
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Use the Get Status card if you want to find the
current status value. If you give it an empty
value box, Hank will put the current status into

the box.

Hank: Greater Than

[Hank: Greater Than |
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Use the Greater Than card to test to see if one

number is greater than another. If the value in
the first column is greater than the value in the
second column, Hank will set the status to OK,

and otherwise the status will be set to Fail.

Hank: Increment
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Use the Increment card to add an amount to a
variable, which should already contain a
number. Put the variable in the first column,
and the amount you want to add to it in the
second column, and Hank will add the amount

to the variable.

Hank: Is Empty
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Use the Is Empty card to ask Hank whether a
given value box is empty or not. The status will
be set to OK if the value box is empty,

otherwise it will be set to Fail.

Hank: Length
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Use the Length card to find out how many
elements there are in a composite value. Hank
will put the length of the value in the first
column into the empty variable in the second

column. The status is always set to OK.

Hank: Less Than
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Use the Less Than card to test to see if one
number is less than another. If the value in the
first column is less than the value in the second
column, Hank will set the status to OK, and

otherwise the status will be set to Fail.

Hank: Make Empty
[Hank: Make Empty
[value Box __ |
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Use the Make Empty card to tell Hank to

throw away the contents of a given value box.

Hank: Match

[Hank: Match 1
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Use the Match card to match a pattern against a
value. The Match card has two columns, and
matches the pattern in the Pattern column with
the value in the Value column. Variables in the
pattern may acquire values, and the status is set
to OK if the pattern matches, or Fail if it
doesn’t. (Hank doesn't care which order the
columns are in, it looks for the columns by

name.)



Hank: Multiply
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Use the Multiply card to multiply two numbers
together. If you put the numbers you want to
multiply into the first two columns, and an
empty value box in the third, Hank will
multiply the numbers and put the answer into

the empty value box.

Hank: Put Cell Value
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Use the Put Cell Value card to put a new value
into a Fact Card’s cell. Give the name of the
Fact Card in the title, for example, to look in
the card “Upon”, use “Hank: Put Cell Value:
Upon”. Hank will then look for this Fact Card,
find the given column and row, and put the
value into the given cell. If Hank couldn't get
the cell for some reason, the status will be set to
Fail.

Hank: Random
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Use the Random card to give you a random
number. The number returned will be a whole
number between 1 and the number you put in
the first column, Value, and it will be put into

the variable in the second column, Result.

Hank: Remove from Card
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Use Remove from Card if you want to remove
arow from a Fact Card. Give the name of the
Fact Card in the title, for example, to remove
from a card “Upon”, use “Hank: Remove from
Card: Upon”. Hank will then look for this Fact

Card, and will try to remove the given row. If

a row is removed, Hank will set the status to
OK, otherwise Fail.

Hank: Same

[Hank: same |
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Use the Same card to find out if two values are
the same. If they are the same, the status will be
set to OK, otherwise it will be set to Fail.

Hank: Say
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Use the Say card when you want Hank to print
out some text. The Say card will take as many
columns and values as you like, and then prints

them all out in the Control Panel.

Hank: Say In Dialog
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Use the Say In Dialog card when you want
Hank to display a message in a dialog window.
The Say In Dialog card will take as many
columns and values as you like, and then prints
them all out in the dialog box. The dialog will
contain OK and Fail buttons, and the status will
be set to the value corresponding to your

selection.

Hank: Set Status
[Fank: et Stivh

Use the Set Status card if you want to set the
status to a new value. If'you give it a value,

Hank will put that value into the status.



Hank: Shuffle
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Use the Shuffle card to shuffle all the rows in a
Fact Card. The Shuffle card doesn’t need or use
any of the columns or rows, and ignores them.
The rows in the Fact Card are reordered, more

or less at random.

Hank: Sort
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Use the Sort card to sort all the rows in a Fact
Card. The Sort card doesn’t need or use any of
the columns or rows, and ignores them. The
rows in the Fact Card are simply sorted so that

the alphabetically earlier items come first.

Hank: Subtract

Use the Subtract card to take one number from
another. Ifyou put the numbers you want to
subtract into the first two columns, and an
empty value box in the third, Hank will put the
difference between them into the empty value

box.



Chapter 5. Hank reference

This section has yet to be written. It will cover
all the commands available through Hank’s
menus. Most of the commands that have not
already been described are only of use to those
using Hank for purposes other than cognitive

modelling.
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